Pascal. паскаль. Написать программу, которая меняет знак всех положительных элементов,...

0 голосов
53 просмотров

Pascal. паскаль. Написать программу, которая меняет знак всех положительных элементов, расположенных в строке и столбце матрицы с максимальным элементом


Информатика (54 баллов) | 53 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program gt;
var a:array[1..100,1..100]of integer;
n,m,i,j,max,h,l:integer;
begin
read(n,m);
max:=-maxint;
for i:=1 to n do
for j:=1 to m do
begin
read(a[i,j]);
if(a[i,j]>max)then begin
max:=a[i,j];
h:=i;l:=j;
end;
for j:=1 to m do
a[h,j]:=-a[h,j];
for i:=1 to n do
a[i,l]:=-a[i,l];
a[h,l]:=-a[h,l];
for i:=1 to n do
begin
for j:=1 to m do
write(a[i,j],' ');
writeln;
end;
end.

(6.6k баллов)