Элементы заданной матрицы A(m,n)-целые числа. Напишите программу вычисляющую сумму и...

0 голосов
46 просмотров

Элементы заданной матрицы A(m,n)-целые числа. Напишите программу вычисляющую сумму и произведения элементов, которые кратны 3 или 2.


Информатика (15 баллов) | 46 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  a                      : array [1..100,1..100] of longint;
  n,m,i,j,sum,mnj : longint;
begin
  readln(n,m);
  for i:=1 to n do 
    for j:=1 to m do read(a[i,j]);
  sum:=0;
   mnj :=1;
 for i:=1 to n do 
    for j:=1 to m do 
      if (a[i,j] mod 3)=0 or ((a[i,j] mod 2)=0) then begin sum:=sum+a[i,j]); mnj:=mnj*a[i,j]; end;
  writeln(sum,' ',mnj);
 
end.

(202 баллов)
0

Выбивает ошибку if (a[i,j] mod 3)=0 or ((a[i,j] mod 2)=0) then begin sum:=sum+a[i,j]); на слове then .Я программу как в точности как у вас скопировал.