Напишите программу, которая "разворачивает" число наоборот, например, из числа 123 строит...

0 голосов
155 просмотров

Напишите программу, которая "разворачивает" число наоборот, например, из числа 123 строит число 321. Используйте функцию для выполнения этой операции. PASCAL


Информатика (14 баллов) | 155 просмотров
Дан 1 ответ
0 голосов
function reverse(s:string):string;
var s1:string;
i:integer;
begin
for i:=1 to length(s) do
s1:=s[i]+s1;
reverse:=s1;
end;

var s:string;
begin
readln(s);
s:=reverse(s);
writeln(s);
end.

(213 баллов)