Помогите пожалуйста!!!СРОЧНО!!! Прошу!!!Написать программу в паскале!!! Составить...

0 голосов
22 просмотров

Помогите пожалуйста!!!СРОЧНО!!! Прошу!!!Написать программу в паскале!!!


Составить процедуру, заменяющую в исходной строке символов все единицы нулями и все нули единицами. Замена выполняется, начиная с заданной позиции строки.


Информатика (63 баллов) | 22 просмотров
Дан 1 ответ
0 голосов

Var
k:integer;
s:string;
procedure Zamena(var ss:string; p:integer);
var
i:integer;
begin
for i:=p to length(ss) do
begin
if ss[i]='1' then ss[i]:='0' else
if ss[i]='0' then ss[i]:='1';
end;
end;
begin
writeln('Введите строку: ');
readln(s);
writeln('Введите позицию с которой начинать замену: ');
readln(k);
Zamena(s,k);
writeln('Измененная строка: ',s);
end.

(884 баллов)