Составьте программу, меняющую в слове Х все сочетания "кар" ** сочетание "акр"

0 голосов
27 просмотров

Составьте программу, меняющую в слове Х все сочетания "кар" на сочетание "акр"


Информатика (19 баллов) | 27 просмотров
Дан 1 ответ
0 голосов

#include
#include

int main()
{  
  std::string x;
  std::cin >> x;

  int p = x.find("kap");
  while (p > 0)
  {
    x.replace(p, 3, "akp");
    p = x.find("kap");
  }  
  std::cout << x;<br>
  return 0;
}

(3.2k баллов)