Дан массив из 8 элементов целого типа равный :-8,13,4,-6,7,10,-5.Напишите программу...

0 голосов
24 просмотров

Дан массив из 8 элементов целого типа равный :-8,13,4,-6,7,10,-5.Напишите программу ,которая заменит все положительные числа на 1 ,а все отрицательные увеличит на 10.Преобразованный массив вывести на экран в строчку через запятую


Информатика (18 баллов) | 24 просмотров
Дан 1 ответ
0 голосов

#include

int main() {
  int a[] = { -8, 13, 4, -6, 7, 10, -5 };
  for (int i = 0; i < 7; ++i)
      std::cout << ((a[i] < 0) ? a[i] += 10 : a[i] = 1) << ","; </span>
   return 0;
}

(3.2k баллов)