Напишите программу, определяющую, лежит ли точка А(ха, ya ): а) ** прямой y = kx + L, над...

0 голосов
160 просмотров

Напишите программу, определяющую, лежит ли точка А(ха, ya ): а) на прямой y = kx + L, над ней или под ней.


Информатика (25 баллов) | 160 просмотров
Дан 1 ответ
0 голосов

Var
x,y,l,k,w:real;
begin
writeln('Введите координаты точки');
read(x,y);
writeln('Введите k и l');
read(k,l);
w:=k*x+l;
If w=y then
writeln('Точка лежит на прямой')
else
If wwriteln('Точка лежит над прямой')
else
writeln('Точка лежит под прямой');
end.

(1.4k баллов)