Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке...

0 голосов
29 просмотров

Помогите решить две задичи
Задача: Написать программу, которая
а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран
б) удаляет все буквы 'а' из строки и выводит новую строку на экран


Информатика (20 баллов) | 29 просмотров
Дан 1 ответ
0 голосов

Var st:string;   
      i:integer;
begin
writeln('Введите строку:');
readln(st);
for i:=1 to length(st) do begin
  if st[i]='a' then
  st[i]:='o';
end;
writeln(st);
end.





var st:string;    
      i:integer;
begin
writeln('Введите строку:');
readln(st);
for i:=1 to length(st) do begin
  if st[i]='a' then
  delete(st,i,1);
end;
writeln(st);
end.








(227 баллов)