Написать программу для решения задачи a) Удалить из текста все введенные символы. b) В...

0 голосов
35 просмотров

Написать программу для решения задачи
a) Удалить из текста все введенные символы.

b) В заданном тексте после каждого знака ‘–’ и перед каждым таким знаком вставить пробел, если его там нет.


Информатика (22 баллов) | 35 просмотров
0

Паскаль? Какая версия? Турбо, Фри, АВС, АВС.NET или что-то еще?

0

ABC NET

0

Там это сделать ну очень просто)))))

0

так ты сделаешь? буду очень благодарен я учусь на историч отделении в информ не знаю ничего.

Дан 1 ответ
0 голосов
Правильный ответ

Var
  s, s_rej, s2: string;
  i: integer;

begin
  Write('Введите текст: '); Readln(s);
  Write('Введите исключаемые символы ПОДРЯД: '); Readln(s_rej);
  s2 := '';
  for i := 1 to Length(s) do
    if Pos(s[i], s_Rej) = 0 then s2 := s2 + s[i];
  Writeln('Обработанный текст: ', s2)
end.

Тестовое решение:
Введите текст: Пример текста, из которого будут исключены гласные буквы
Введите исключаемые символы ПОДРЯД: аеёиоуэюя
Обработанный текст: Прмр ткст, з ктрг бдт склчны глсны бквы

var
  s, s2: string;
  i: integer;
  c:array of string;

begin
  Write('Введите текст: '); Readln(s);
  s:=Trim(s);
  c:=s.Split('-');
  s2:=Trim(c[0]);
  for i:=1 to Length(c)-1 do
    s2:=s2+' - '+Trim(c[i]);
  Writeln('Обработанный текст: ', s2)
end.

Тестовое решение:
Введите текст:    тестовая   -строка - в ней много-много тире в разных-  преразных вариантах - и в таком даже
Обработанный текст: тестовая - строка - в ней много - много тире в разных - преразных вариантах - и в таком даже





(142k баллов)