Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит...

0 голосов
385 просмотров

Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) .

Входные данные
Входная строка содержит два вещественных числа a и b , разделённых пробелом. Гарантируется, что a < b .

Выходные данные
Нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.


Информатика | 385 просмотров
Дан 1 ответ
0 голосов

Var a, b: real; i: integer;
begin 
randomize; 
readln(a,b); 
for i:= 1 to 5 do   
write((Random()*(b-a)+a):0:3, ' ');
end.

(3.8k баллов)
0

а надо как?

0

а, через пробел...

0

смотри