Напишите программу, которая: А) определяет, есть ли среди цифр заданного целого...

0 голосов
98 просмотров

Напишите программу, которая:
А) определяет, есть ли среди цифр заданного целого трехзначного числа одинаковые;
Б) явл. ли число "перевертышем", т.е. Числом, десятичная запись которого читается одинаково слева направо и справа налево.


Информатика (60 баллов) | 98 просмотров
Дан 1 ответ
0 голосов

А) Program cifr;
Uses crt;
var n,l:integer; s:string;
Begin
read(n);
str(n,s);
l:=length(s);
  if (s[1]<>s[2]) and (s[2]<>s[3]) and (s[1]<>s[3])
    then begin writeln('Одинаковых цифр нет') end
    else writeln('Одинаковые цифры присутствуют');
end.

Б) Program Stroke;
Uses Crt;
Var s: string; n,i,j,l: integer;
Begin
  ReadLn(n);
  str(n,s);
  l:=length(s);
  j:=0;
for i := 1 to l div 2 do begin
  if s[i]=s[length(s)-i+1]
    then j:=1 end;
if j=1 then 
    writeln('Да, число является палиндромом')
    else writeln('Нет, число не является палиндромом');
End.

(162 баллов)