Составить программу ** языке паскаль задание: дана матрица А(N, N). Составить программу...

0 голосов
70 просмотров

Составить программу на языке паскаль
задание: дана матрица А(N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали


Информатика (123 баллов) | 70 просмотров
Дан 1 ответ
0 голосов

Var n, i, j, ans : integer;
a : array[,] of integer;
begin
    read(n);
    ans := 0;
    SetLength(a, n + 1, n + 1);
    for i := 1 to n do
        for j := 1 to n do
            read(a[i, j]);
    for i := 1 to n do
        for j := i + 1 to n do
            if (a[i, j] > 0) then
                ans := ans + 1;
    writeln(ans);
end.

(8.2k баллов)
0

а ans и setLength это что?)

0

SetLength - задать в двумерном массиве a n строк и n столбцов. Можно этого не делать, а просто написать во второй строке, например, a : array[3000, 3000] of integer; или другие значения. ans - ответ задачи