Напишите программу вычисления суммы квадратов чисел от 50 до 150.Напишите программу...

0 голосов
34 просмотров
Напишите программу вычисления суммы квадратов чисел от 50 до 150.
Напишите программу вычисления квадрата суммы чисел от 50 до 150.

Информатика (12 баллов) | 34 просмотров
Дан 1 ответ
0 голосов

Решение на Паскале
var i, sum, s, ks :integer;
Begin
s:= 0;
for i:=50 to 150 do s:=s+i*i;
sum:=0;
for i:=50 to 150 do sum:=sum+i;
ks:=sqr(sum);
writeLn('Сумма квадратов целых чисел от 50 до 150 = ',s);
writeLn('Квадрат суммы целых чисел от 50 до 150 = ',ks);
end.

(8.8k баллов)