Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее...

0 голосов
37 просмотров

Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее арифметическое этих чисел


Информатика (25 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

Var a,n,sum: integer;
begin
sum:=0;
n:=0;
readln(a);
while a<>0 do
begin
sum:=sum+a;
n:=n+1;
end;
writeln(sum/n);
end.

(1.5k баллов)