Напишите программу, которая вводит натуральные числа a и b , и выводит квадраты...

0 голосов
235 просмотров

Напишите программу, которая вводит натуральные числа a и b , и выводит квадраты натуральных чисел в диапазоне [ a , b ] .
PS: на Pascal'е


Информатика (329 баллов) | 235 просмотров
0

в диапозоне это тип от а до б?

0

ты тут?

0

да

0

например введены числа 3 5, программа выдаст 9 16 25

Дан 1 ответ
0 голосов
Правильный ответ

Var
i,a,b:Integer;
Begin
 Read(a,b);
 for i:=a to b do
  begin
   Write(i*i,' ');
  end;
end.

(1.5k баллов)
0

Спасибо, не мог понять в чём ошибка в программе, в конце программы выдавало какую-то левую цифру. Теперь понял))