Составить программу в паскаль

0 голосов
45 просмотров

Составить программу в паскаль


image

Информатика (30 баллов) | 45 просмотров
Дан 1 ответ
0 голосов
function toBool(a: integer): boolean;
begin
  toBool := a > 0;
end;

var
  a, b, ans: boolean;
  i, j: word;

begin
  writeln('Таблица истинности - true', #13, 'Вычисление значения функции - false');
  readln(ans);
  
  case (ans) of
    true:
      begin
        writeln();
        writeln('a':4, 'b':7, 'not a':10, 'not b':7, 'f':5);
        for i := 0 to 1 do
          for j := 0 to 1 do
            writeln(toBool(i):6, '|', toBool(j):6, '||', not toBool(i):6, '|', not toBool(j):6, '|', (not toBool(i) or not toBool(j)):6);
      end;
    false:
      begin
        write('Введите a: '); readln(a);
        write('Введите b: '); readln(b);
        
        writeln('f = ', not a or not b);
      end;
  end;
end.
(16.9k баллов)