Составить программу рисования ромашки ** паскале.

0 голосов
135 просмотров

Составить программу рисования ромашки на паскале.


Информатика (285 баллов) | 135 просмотров
Дан 1 ответ
0 голосов

Вот программа, довольно понятная, 

комментарии:

lepestkov:=13; - тут можно менять количесто лепестков

fi:=2*3.14*i/lepestkov;

2*Pi - это полный угол 360 градусов. мы делим его на количество лепестков. Таким образом мы получаем угол на который должен идти лепесток.

 

Картинка ромашки во вложении. если такая не пойдет, отмечай как нарушение.

 

uses crt, graph;
var gDriver, gMode, errCode:integer;
i:integer;
lepestkov:integer;
fi,x,y:real;
radius:integer;
begin
gDriver:=Detect;
InitGraph(gDriver, gMode,'');
ErrCode:=GraphResult;
if(GraphResult <> grOK) then
begin
writeln('ne mogu naiti file graphiki');
readln;
end;
setcolor(green);
line(320,200,320,400);
setcolor(yellow);
setFillStyle(SolidFill, yellow);
fillellipse(320,200,15,15);
setFillStyle(SolidFill, white);
setcolor(white);
lepestkov:=13;
for i:=1 to lepestkov do
begin
fi:=2*3.14*i/lepestkov;
for radius:=24 to 60 do
begin
x:=320 + radius*cos(fi);
y:=200 + radius*sin(fi);
fillellipse(round(x),round(y),10,10);
end;
end;
readln;
end.


image
(1.8k баллов)