Срочно!!!! Помогите пожалуйста!!! Программы паскалясоставьте программу решения...

0 голосов
23 просмотров

Срочно!!!! Помогите пожалуйста!!! Программы паскаля
составьте программу решения квадратного уравнения ax2 +bx +c=0 Коэффициенты a в с введите с клавиатуры. Выведите на экран значения корней x1 x2 если уравнение имеет два корня, значение x, если уравнение имеет один корень, или сообщение "Нет корней", если уравнение не имеет корней.


Информатика (42 баллов) | 23 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  a, b, c, d, x1, x2: real;

begin
  Write('Введите через пробел значения a,b,c: ');
  Readln(a, b, c);
  d := sqr(b) - 4 * a * c;
  if d < 0 then Writeln('Нет действительных корней')
  else if d = 0 then Writeln('Один корень ', -b / (2 * a))
  else
  begin
    d := sqrt(d);
    x1 := (-b - d) / (2 * a);
    x2 := (-b + d) / (2 * a);
    Writeln('x1=', x1, ', x2=', x2)
  end
end.

Тестовое решение:
Введите через пробел значения a,b,c: 4 3.2 -2
x1=-1.2124038404636, x2=0.412403840463596

ax^2+bx+c=0 \\ D=b^2-4ac \\ x= \frac{-b\mp \sqrt{D}}{2a}

(142k баллов)
0

Значит Вы не сможете решить эту задачу

0

Нельзя решить квадратное уравнения, не извлекая квадратный корень

0

я в 8 классе, в 7 еще не проходят такое

0

Я не понял, Вы что от меня хотите? Чтобы я Вам рассказал, как найти корень квадратного уравнения не по той формуле, по которой их решают? Еще раз: НЕЛЬЗЯ найти число по его квадрату, если не использовать извлечение квадратного корня..

0

Вы попросили решение - я его написал. Другого НЕ СУЩЕСТВУЕТ.

0

Т.е. можно писать программу с вариациями, но sqrt там будет всегда

0

хорошо. а правильно sqrt или sqr? или это разные команды?

0

sqr (от англ. Square) - это функция возведения в квадрат. sqrt (от англ. Square Root) - это функция извлечения квадратного корня, обратная функции sqr

0

спасибо

0

Пожалуйста. Спасибо тут принято выражать специальной кнопочкой. Звездочки рядом - это размер "спасибо" по 5-балльной системе.