Написать программу нахождения суиммы большего и меньшего из 3 чисел

0 голосов
71 просмотров

Написать программу нахождения суиммы большего и меньшего из 3 чисел


Информатика (12 баллов) | 71 просмотров
Дан 1 ответ
0 голосов

#include
#include
using namespace std;

int main()
{
 int selection;
 float first, second, result;
 cout << "Калькулятор\n";<br> cout << "1. Сложение\n";<br> cout << "2. Вычитание\n";<br> cout << "3. Умножение\n";<br> cout << "4. Деление\n";<br> cout << "0. О программе\n\n";<br> cout << "Введите цифру: ";<br> cin >> selection;
 switch(selection)
 {
  case 1:
   cout << "Введите первое слагаемое: ";<br>   cin >> first;
   cout << "Введите второе слагаемое: ";<br>   cin >> second;
   result = first + second;
   cout << "Результат: " << result << "\n";<br>   break;
  case 2:
   cout << "Введите уменьшаемое: ";<br>   cin >> first;
   cout << "Введите вычитаемое: ";<br>   cin >> second;
   result = first - second;
   cout << "Результат: " << result << "\n";<br>   break;
  case 3:
   cout << "Введите первый множитель: ";<br>   cin >> first;
   cout << "Введите второй множитель: ";<br>   cin >> second;
   result = first * second;
   cout << "Результат: " << result << "\n";<br>   break;
  case 4:
   cout << "Введите делимое: ";<br>   cin >> first;
   cout << "Введите делитель: ";<br>   cin >> second;
   result = first / second;
   cout << "Результат: " << result << "\n";<br>   break;
  case 0:
   cout << "Программа 'Калькулятор'.\n";<br>   break;
  default:
   cout << "Необходимо ввести цифру от 0 до 4 в зависимости от Вашего выбора!\n";<br> }
return 0;
}

(119 баллов)