Написать программу с использованием оператора while do Портному принесли кусок ткани...

0 голосов
40 просмотров

Написать программу с использованием оператора while do


Портному принесли кусок ткани длиной 400 метров ,на одну занавеску требуется 3 метра ткани,рассчитать сколько занавесок получится и остаток также, учитывая ,что портной не умеет делить, а только складывать и вычитать


Информатика (17 баллов) | 40 просмотров
0

на языке Паскаль?

Дан 1 ответ
0 голосов
Правильный ответ

Program portnoy;
var L,k : integer ; 
begin
L=400;
k=0;
While L>=3 do begin
L=L-3;
k=k+1;
end;
WriteLn ( ' получится ',k,' занавесок и останется ',L,' метров ткани');
end.

(360 баллов)
0

с оператором WriteLn мог накосячить, так как не помню, как записывать внутри скобки, а остальное должно быть верно