Написать программу Паскаль - Вывести ** экран элементы , которые больше значения...

0 голосов
32 просмотров

Написать программу Паскаль - Вывести на экран элементы , которые больше значения элемента, номер которого введен с клавиатуры


Информатика (12 баллов) | 32 просмотров
Дан 1 ответ
0 голосов

Var
  arr : array [1..30] of integer;
  i, number : integer;
begin
  //Заполнение массива случайными числами
  for i := 1 to 30 do
    arr[i] := Random(10000) - 5000;
  //---
  //Считывание номера элемента и проверка на соответствие условию
  write('Введите число: ');
  readln(number);
  if not (number in [1..30]) then
  begin
    write('Ошибка. Номер элемента выходит за границу массива');
    Exit;
  end;
  //---
  //Вывод массива с учётом условия
  for i := 1 to 30 do
    if arr[i] > arr[number] then
      write(arr[i], ' ');
  //---
end.

(918 баллов)
0

спасибо)

0

Всегда пожалуйста :)