Помогите написать программу ** паскаль и блок схемуНайти сумму1,1-1,2+1,3.......1.nn-...

0 голосов
39 просмотров

Помогите написать программу на паскаль и блок схему

Найти сумму
1,1-1,2+1,3.......1.n
n- целое, вводится с клавиатуры
i- параметр цикла
j- меняет знак j:=-j


Информатика (20 баллов) | 39 просмотров
0

члены до н-ого числа

0

такие же

0

1.1-1.2+1.3-1.4 и т.д

Дан 1 ответ
0 голосов
Правильный ответ

Var
  i,j,s,n:integer;
begin
  write('Задайте значение n: ');
  readln(n);
  s:=1;
  j:=-1;
  for i:=1 to n do
    begin
    s:=s+i+j;
    j:=-j
    end;
  writeln('s=',s);
end.

Тестовое решение:

Задайте значение n: 5
s=15


(142k баллов)