Написать программу для решения задачи. Вводятся две строки символов. Определить, которая...

0 голосов
41 просмотров

Написать программу для решения задачи.

Вводятся две строки символов. Определить, которая из них больше.
вот пример:
Var _______:string;

Begin

writeln('_________________');

readln(_____);

writeln('_________________');

readln(_____);

if S1>S2
then


writeln(' ______ больше')

else

if _____
then


writeln('
______
больше ')


else

writeln('одинаковые')

readln;

End.


Информатика (22 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Можно даже немного короче:
var:
  s1,s2:string;
begin
  writeln('Vvedite pervyu stroky');
  readln(s1);
  writeln('Vvedite vtoryu stroky');
  readln(s2);
if (Length(s1))>(Length(s2)) then
  writeln('Pervaya stroka bolshe,chem vtoraya')
else
  writeln('Vtoraya stroka bolshe,chem pervaya');
  readln;
end.

Проверял - всё работает, ошибок нет.

(969 баллов)