Как написать программу для сложения 5 чисел в Паскале?

0 голосов
56 просмотров

Как написать программу для сложения 5 чисел в Паскале?


Информатика (12 баллов) | 56 просмотров
Дан 1 ответ
0 голосов

Var a,x:integer;
i,s:integer;
begin
writeln('введите целое число');
readln( a );
x:=a;
s:=0;
while ( x<>0 ) do 
begin
s := s + (x mod 10);
x := x div 10;
end;
writeln( 'Сумма цифр числа ',a,' = ', s );
end.

(36 баллов)