Помогите пожалуйста написать программу в Паскале

0 голосов
36 просмотров

Помогите пожалуйста написать программу в Паскале


image
image

Информатика (62 баллов) | 36 просмотров
Дан 1 ответ
0 голосов
var
  a: array [1..4, 1..5] of integer;
  i, j: byte;
begin
  for i := 1 to 4 do
  begin
    for j := 1 to 5 do
    begin
      a[i, j] := random(10, 99);
      write(a[i, j]:3);
    end;
    writeln();
  end;
end.
--------------------------------------
const
  n = 5;
var
  a: array [1..n] of integer;
  i, p: integer;
begin
  p := 1;
  for i := 1 to n do
  begin
    readln(a[i]);
    if (i mod 2 = 0) then
      p := p * i;
  end;
  writeln();
  writeln(p);
end.
(16.9k баллов)