Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и...

0 голосов
179 просмотров

Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и выводит на экран соответствующий результат.Задача 2) Дано целое число. Написать программу, которая заменяет его на 0, если число отрицательное, и выводит его без изменений, противном случае.Задача 3) Дано целое число n. Написать программу увеличивающую его на 10, если число больше 0.


Информатика (172 баллов) | 179 просмотров
0

что выводить в 3-ей задаче если число меньше 0?

0

если меньше просто вывести

0

тогда ниже все правильно написано

0

Спасибо :)

Дан 1 ответ
0 голосов

Задача 1
var
a,b:Integer;
Begin
 Read(a,b);
 if (a>b) then Writeln(b)
  else if (a  else Writeln('Числа равны');
end.

Задача 2
var
n:Integer;
Begin
 Read(n);
 if (n<0) then Writeln(0)<br>  else Writeln(n);
end.

3адача 3.
var
n:Integer;
Begin
 Read(n);
 if (n>0) then Writeln(n+10)
  else Writeln(n);
end.


(1.5k баллов)