Составьте программу которая выводит ** экран нечетные числа от 1 до 50 в порядке убывания...

0 голосов
45 просмотров

Составьте программу которая выводит на экран нечетные числа от 1 до 50 в порядке убывания c циклом While


Информатика (12 баллов) | 45 просмотров
0

Надо без dec и n-=2

Дан 1 ответ
0 голосов
var
  n: integer := 50;

begin
  if (n mod 2 = 0) then
    dec(n);

  while (n >= 1) do
  begin
    writeln(n);
    n -= 2;
  end;
end.
(16.9k баллов)
0

Я учащийся 8 класса. Мы dec не прходили

0

1. Просто уменьшение на 1, для универсальности
2. Вас карают за чтение документации?
3. И ладно, n -= 1 или n := n - 1