Написать программу ** pascal:дана матрица b состоящая из целых чисел получить матрицу r...

0 голосов
46 просмотров

Написать программу на pascal:дана матрица b состоящая из целых чисел получить матрицу r значения которой равны удвоенным значениям матрицы b


Информатика (17 баллов) | 46 просмотров
Дано ответов: 2
0 голосов

Var b:array[1..1000, 1..1000] of integer;
n,m,i,j:integer;
Begin
Writeln('Введите количество столбцов');
Readln(n);
Writeln('Введите количество строк');
Readln(m);
For i:=1 to n do
For j:=1 to m do begin
Readln(b[i,j]);
b[i,j]:=2*b[i,j];
end;
end.


image
0

Если с помощью вашего кода захочу создать массив из 3строк и 4 столбцов, то Я получу массив из 4 строк и из 3 столбцов. И еще описании гласит Получит матрицу R с удвоенным значениям матрицы B, а в вашем коде удвоенные значения записываются в тот же матрицу B

0 голосов

Uses crt;
var b:array[1..100,1..100] of integer;
       r:array[1..100,1..100] of integer;
str,stb,i,j:integer;
Begin
randomize;
clrscr;
Writeln('Введите количество строк :  ');
Read(str);
Writeln('Введите количество Столбцов:  ');
Readln(stb);
writeln;
writeln('Matrica B');
For i:=1 to str do
begin
For j:=1 to stb do begin
b[i,j]:=random(30)+1;
r[i,j]:=2*b[i,j];
write(b[i,j]:3,'  ');
end;
writeln;
end;
writeln;
writeln('Matrica R');
for i:=1 to str do 
begin
for j:=1 to stb do
begin
write(r[i,j]:3,'  ');
end;
writeln;
end;
readln;
end.

Запускаем , и первом делом создаём двухмерный массив Введя числа(когда программа запросит) не превышающий числа 100  (Строки и столбцы) ... после как мы ввели числа создается массив заполняя массив случайными числами в диапазоне 1..30.. И выводим Массив B, после удваиваем каждый элемент и заносим удвоенный результат в масссив R, и тоже выводим

(456 баллов)