Составьте программу которая проверяет равны ли 3 введенных целых числа, и выводит **...

0 голосов
77 просмотров

Составьте программу которая проверяет равны ли 3 введенных целых числа, и выводит на экран соответствующее сообщение"равны"либо "неравны "


Информатика (37 баллов) | 77 просмотров
Дано ответов: 2
0 голосов

Program zadacha;
var
a,b,c:integer;
begin
read(a,b,c);
if (a=b)and(b=c) then 
write('Равны')
else
write('Не равны')
end.

(157 баллов)
0 голосов
var
  a, b: real;
  c: boolean; //Чтобы меньше памяти кушало :)

begin
  readln(a, b);
  if (a = b) then
    c := true;
  readln(b);
  if ((b = a) and c) then
    writeln('Равны')
  else
    writeln('Не равны');
end.
(16.9k баллов)