3. Напишите программу ** Паскале вывода значения true, если точка с заданными...

0 голосов
43 просмотров

3. Напишите программу на Паскале вывода значения true, если точка с заданными координатами (х,у) лежит внутри заштрихованной области и false, если не лежит.


Информатика (18 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

var x, y: integer;

 

 

begin

  readln (x);

  readln (y);

  if (y > 0) and (y < 4) and (x < 4) and (x > -4) and (sqrt (x*x + y*y) < sqrt (4*4 * 4*4))

    then writeln ('true')

  else writeln ('false');

end.

  

если считать, что 1 клетка равна еденице.

  

(300 баллов)