Известны три натуральных числа C– часы, M – минуты, S – секунды. Написать программу...

0 голосов
76 просмотров

Известны три натуральных числа C– часы, M – минуты, S –
секунды. Написать программу используя условный оператор, которая
определяет время через 15 секунд.

Пожалуйста нужно сделать через Pascal !



Информатика (21 баллов) | 76 просмотров
Дан 1 ответ
0 голосов

Var
c,m,s:integer;
begin
readln(c,m,s);
if s>=45 then begin
m:=m+1;
s:=s+15-60;
end
else s:=s+15;
if m>=59 then begin
 c:=c+1;
m:=0;
end;
if c>=24 then c:=0;
writeln(c,' ',m,' ',s);
end.

(3.4k баллов)