Написать программу в паскалеДано три массива A,B,C состоящее из 10 элементов.Присвоить...

0 голосов
60 просмотров
Написать программу в паскале
Дано три массива A,B,C состоящее из 10 элементов.Присвоить массиву D среднее арифметическое каждого элемента этих трех массивов.

Информатика (12 баллов) | 60 просмотров
0

подмечено ли там , Чем заполнять массивы ?

0

или модно псевдослучайно

Дан 1 ответ
0 голосов

Uses crt;
Var a,b,c,d;array [1..10] of integer;
I:integer;
Begin
Clrscr;
Begin
For i:=1 to 10 do
Begin
a[i]:=random(50)+1;
b[i]:=random(50)+1;
c[i]:=random(50)+1;
d[i]:=(a[i]+b[i]+c[i]) div 3;
end;
Write('A) ');
For i:=1 to 10 do
write(a[i],' ');
Writeln;

write('B) ');
For i:=1 to 10 do
write(b[i],' ');
Writeln;

Write('C) ');
For i:=1 to 10 do
write(c[i],' ');
Writeln;

Writeln('Средние значения ');
Write('D) ');
For i:=1 to 10 do
write(d[i],' ');
Writeln;
Readkey;
End.

(456 баллов)
0

сначала заполняем массивы ABC случайными числами в интервале 1..50 , потом заполняем массив результатами как подобает , и последние четыре цикла выводит содержимое массивов

0

для надежности после 4 строе (сверху в низ) напишите строку Randomize;

0

спасибо большое