Написать программу которая находит сумму цифр числа Паскаль( ну или хотя бы идейку...

0 голосов
60 просмотров

Написать программу которая находит сумму цифр числа
Паскаль
( ну или хотя бы идейку подкиньте)


Информатика (48 баллов) | 60 просмотров
Дан 1 ответ
0 голосов

Program summa;
var a,x:integer; 
i,s:integer;
begin 
writeln('введите целое число');
 readln( a );
 x:=a; 
s:=0; 
while ( x<>0 ) do  begin   s := s + (x mod 10); 
  x := x div 10; 
end;
writeln( 'Сумма цифр числа ',a,' = ', s );
end.

0

оооооо, спасибо вам большое)