Дано целое число. Написать программу, которая заменяет его ** 0, если число...

0 голосов
36 просмотров

Дано целое число. Написать программу, которая заменяет его на 0, если число отрицательное, и выводит его без изменений, в противном случае.


Информатика (12 баллов) | 36 просмотров
Дан 1 ответ
0 голосов

Вот такая программа (для PascalABC.NET). И еще ты не сказал, что делать с числом, если оно равно 0?

var a,x:integer;
begin
read(a);
if a<0 then x:=0 else x:=a;<br>writeln(x);
end.

Не забудь откомпилировать перед проверкой.

(349 баллов)