Помогите написать программу в pascal.Дан набор слов, разделенных точкой с запятой (;)....

0 голосов
65 просмотров

Помогите написать программу в pascal.Дан набор слов, разделенных точкой с запятой (;). Набор заканчивается двоеточием (:). Определить, сколько в нем слов, заканчивающихся буквой а.


Информатика (38 баллов) | 65 просмотров
Дан 1 ответ
0 голосов
var
  str: string;
  i  : byte;

begin
  readln(str);
  str := str.Replace(':', '');
  foreach c: string in str.Split(';') do
    if (c[c.Length] in ['a', 'а']) then //не уточнено, какого алфавита "а"
      i += 1;
  writeln(i);
end.
(16.9k баллов)
0

Зачем? Просто удалить последний символ, чтобы не смущать программу им

0

В смысле, в ведённой строке удалить

0

Чтобы однозначно можно было сказать: последняя буква последнего слова - "а", а не ";"