Написать программу в паскаль:Составить таблицу стоимости порций сыра весом 50, 100,150,...

0 голосов
125 просмотров

Написать программу в паскаль:
Составить таблицу стоимости порций сыра весом 50, 100,150, ... 1000 г(цена 1 кг 300р)


Информатика (14 баллов) | 125 просмотров
Дан 1 ответ
0 голосов
var
  s: single := 50; //s: integer;

begin
  //s := 50;
  while (s <= 1000) do<br>  begin
    writeln(s:4, ' гр.', s / 10 * 3:5, ' p.');
    s += 50; //s := s + 50;
  end;
end.
(16.9k баллов)
0

Выдает ошибку, ошибка в single

0

замените на integer, тогда и s += 50 замените на s := s + 50