Составить программу ** паскаль. Слова могут содержать любые символы языка. Найти и...

0 голосов
40 просмотров

Составить программу на паскаль.
Слова могут содержать любые символы языка. Найти и вывести в самом длинномслове все символы, отличные от заглавных латинских букв. Использовать множества.


Информатика (186 баллов) | 40 просмотров
Дан 1 ответ
0 голосов
var  
  a       : array of string;
  str, m: string;

begin
  readln(str);
  a := str.Split(' ');
  foreach str in a do
    if (m.Length < str.Length) then
      m := str;
  foreach kchr: char in m do
    if not (kchr in ['A'..'Z']) then
      write(kchr);
end.
(16.9k баллов)