Введено число от 1 до 1000 включительно. Написать программу, с помощью которой можно...

0 голосов
17 просмотров

Введено число от 1 до 1000 включительно. Написать программу, с помощью которой можно найти сумму цифр числа, введенного пользователем. Писать на С++


Информатика (89 баллов) | 17 просмотров
Дан 1 ответ
0 голосов

#include
using namespace std;
int n;
int sum_digits(int n)
{
  int res = 0;
  while (n > 0)
  {
    res += n % 10;
    n /= 10;
  }
  return res;
}
int main()
{
  cin >> n;
  cout << sum_digits(n);<br>  return 0;
}

(8.2k баллов)