Напишите программу вычисления сумм слагаемых,имеющих вид дроби (i+1)/(i+2),где...

0 голосов
50 просмотров

Напишите программу вычисления сумм слагаемых,имеющих вид дроби (i+1)/(i+2),где i=1,2,3,...,n-данное число.
Помогите,пожалуйста!


Информатика (167 баллов) | 50 просмотров
0

По бейсикуINPUT "N="; NFOR I = 1 TO N S = S + (I + 1) / (I + 2)NEXT IPRINT "S="; S

Дано ответов: 2
0 голосов
Правильный ответ

Если я правильно понял, то вот так.

(1.0k баллов)
0

По Паскалю разве?)

0

да паскалик) язык не был указан...))

0 голосов

VAR 
i: integer; 
s:real; 
BEGIN 
s:=0; 
for i := 1 to 100 do s := s + (i+1)/(i+2); 
writeln('S=',s:0:6); 
END.

(273 баллов)
0

Это по Паскалю?

0

да

0

А по бейсику?

0

Через print?