Написать программу вхождения каждого символа в текст, содержащийся в файле в формате txt,...

0 голосов
77 просмотров

Написать программу вхождения каждого символа в текст, содержащийся в файле в формате txt, на языке программирования высокого уровня BASIC (можно либо на QBasic или на Visual Basic)?


Информатика (15 баллов) | 77 просмотров
0

Вот текст, который содержится текстовый файл: "Ксаверий Феофалактович Грушин, следственный пристав Сыскного управления при московском обер-полицмейстере, облегченно вздохнул и отложил влево, в стопку "просмотрено", сводку важных преступлений за вчерашний день" (не могу к сожалению вставить текст целиком. Программа должна производить количество каждого символа в текст. Более конкретного описания моей задачи. у меня нет. Если Вы не против можем обсудить этот вопрос более подробнее на Майл.ру

0

так алфавитно-цифровые, а вот насчет знаков точно не знаю, но думаю, что да

0

В этом тексте только русский алфавит. Но если вам не сложно, то можно прописать, чтобы считывался и латинский алфавит.

0

а насчет знаков. то нельзя ли прописать строчку программного кода, которая при прочтении текста в файле, считала знаки автоматически

0

через этот чат, я не могу скинуть текст полностью (а он достаточно объемный)

Дан 1 ответ
0 голосов
Правильный ответ

Const
  T = 'АБВГДЕЁЖЗИЙКЛИНОПРСТУФХЦЧШЩЪЫЬЭЮЯабвгдеёжхийклмнопрстуфхцчшщъыьэюя';
  n = 66;//  Количество символов в Т

var
  s,buf: string;
  P: array[1..n] of integer;
  i, k: integer;
  F: Text;

begin
  Assign(F, 'CharCount.txt');
  Reset(F);
  s:='';
  while not SeekEof(F) do begin
    Read(F,buf);
    s:=s+buf
  end;
  Writeln(s);
  for i := 1 to n do P[i] := 0;
  for i := 1 to length(s) do
  begin
    k := Pos(s[i], T);
    if k > 0 then P[k] := P[k] + 1
  end;
  for i := 1 to n do
    if P[i] > 0 then writeln(T[i], ' - ', P[i]:3)
end.

Тестовый пример:
Ксаверий Феофалактович Грушин, следственный пристав Сыскного управления при московском обер-полицмейстере,облегченно вздохнул и отложил влево, в стопку "просмотрено", сводку важных преступлений за вчерашний день
Г -   1
К -   1
С -   1
Ф -   1
а -   8
б -   2
в -  13
г -   2
д -   4
е -  17
ж -   2
х -   2
и -  11
й -   5
к -   6
л -  10
м -   4
н -  13
о -  20
п -   8
р -  11
с -  12
т -   8
у -   6
ф -   1
ц -   1
ч -   3
ш -   2
ы -   3
ь -   1
я -   1




(142k баллов)
0

или VB

0

я уже поняла, что операторы кода отличаются от Basic. Но все же задание поставлено у меня таким образом, что нужно писать программный код на любом Basic, но именно Basic (Free Basic, Liberty Basic)

0

Да, VBA подойдет, кстати в Exsel нужно построить диаграмму встречаемости русских символов и подсчитать процент вхождения каждого из них в текстовый файл по отношению ко всем русским символам.

0

есть, логин: lektra55