Можете помочь написать программу?

0 голосов
43 просмотров

Можете помочь написать программу?


image

Информатика (15 баллов) | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
  n = 10;

var
  a: array[1..n, 1..n] of integer;
  i, j, k, s: integer;

begin
  Writeln('Сгенерированная матрица');
  for i := 1 to n do
  begin
    for j := 1 to n do
    begin
      a[i, j] := abs(n - i - j + 1);
      Write(a[i, j]:2)
    end;
    Writeln
  end;
  Write('Введите номер столбца (1-10): ');
  Readln(k);
  if not (k in [1..10]) then Writeln('Столбца с таким номером не существует')
  else begin
    s := 0;
    for j := 1 to n do s := s + a[k, j];
    Writeln('Сумма элементов по столбцу ', k, ' равна ', s)
  end
end.

Тестовое решение:

Сгенерированная матрица
 9 8 7 6 5 4 3 2 1 0
 8 7 6 5 4 3 2 1 0 1
 7 6 5 4 3 2 1 0 1 2
 6 5 4 3 2 1 0 1 2 3
 5 4 3 2 1 0 1 2 3 4
 4 3 2 1 0 1 2 3 4 5
 3 2 1 0 1 2 3 4 5 6
 2 1 0 1 2 3 4 5 6 7
 1 0 1 2 3 4 5 6 7 8
 0 1 2 3 4 5 6 7 8 9
Введите номер столбца (1-10): 8
Сумма элементов по столбцу 8 равна 31



(142k баллов)
0

Огромное спасибо вам!

0

Размер "спасибо" тут принято обозначать числом "звездочек")))