Составьте программув Паскале, находящую значения максимумов и минимумов

0 голосов
49 просмотров

Составьте программув Паскале, находящую значения максимумов и минимумов


image

Информатика (144 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
x,y,z:integer;

function min(a,b:integer) : integer;
begin
if amin:=a
else
min:=b;
end;

function max(a,b,c:integer) : integer;
begin
if (a>b) AND (a>c) then
max:=a
else
if (b>a) AND (b>c) then
max:=b
else
max:=c;
end;

begin
readln(x,y,z);
writeln( min( max(x,y,2*z),min(y,z) )/(min(x,y)*min(x,y)) );
end.

(2.4k баллов)
0

а откуда авс взялись?

0

a.b.c - это локальные переменные внутри функции

0

спасибо больше!