Написать программу в Pascal, используя массивы. Дано массив А[1..n]. Сделать программу...

0 голосов
31 просмотров

Написать программу в Pascal, используя массивы.
Дано массив А[1..n]. Сделать программу которая выводит те элементы массива? индексы которых являются степени двойки
Желательно с обьяснением строк


Информатика (15 баллов) | 31 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
  n = 100;

var
  a: array[1..n] of integer;
  i: integer;

begin
  //заполняем массив случайными значениями в диапазоне [0;100]
  Randomize; //инициализация датчика случайных чисел
  for i := 1 to n do a[i] := random(100);
  i := 1;  //1 - это два в нулевой степени
  while i < n do
  begin
    writeln('a(', i, ')=', a[i]);
    i := 2 * i;  //удваиваем индекс, чтобы получить очередную степень двойки
  end
end.

Результат работы программы:
a(1)=26
a(2)=21
a(4)=29
a(8)=74
a(16)=23
a(32)=44
a(64)=20


(142k баллов)