Пожалуста!!!!!!!!!!!!!!!!!!!!!!ОЧ срочно!!!!!! Написать программу ** паскале, которая...

0 голосов
34 просмотров

Пожалуста!!!!!!!!!!!!!!!!!!!!!!ОЧ срочно!!!!!!

Написать программу на паскале, которая вводит массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы. Протестировать программу для следующих массивов:

а) 3 5 -2 0 -6 -8 1

б) -1 -2 -3 0 -1 2 3

массивы должны вводися вручную а не рандомно.


Информатика (12 баллов) | 34 просмотров
Дан 1 ответ
0 голосов

var a: array[1..100] of integer;

n, i: integer;

begin

write('Введите количество элементов массива');

readln(n);

write('Вводите элементы массива отделяя их клавишей "Enter"');

for i:=1 to n do 

read(a[i]);

for i:=1 to n do 

if a[i]<0 then write('число ', a[i], ', номер ', i,'; ' );</p>

end.

(116 баллов)