Написать программу вывода max n-числа, где- то от 1 до 100 через массив ,и последующее...

0 голосов
57 просмотров

Написать программу вывода max n-числа, где- то от 1 до 100 через массив ,и последующее сравнивать


Информатика (15 баллов) | 57 просмотров
0

program primer1; Var a: array [1...100] of integer; n i , max, min: integer; be

0

Ну вот, значит все же до 100 элементов целого типа...

0

program primer1; Var a: array [1...100] of integer; n i , max, min: integer; begin writeln(n); for i :< 1 to n do begin a[ i ] := random(101) -90; write (a[ i ] , " -"); end; все что учитель сказал как дальше найти max и min

0

помогите пожалуста

0

А разве Вы минимум просили?

0

мне на выбор или минимум или максимум , что то одно

0

Написал оба

0

напишите хоть что нибудь

0

пожалуйста

0

ну что вы напишете????

Дан 1 ответ
0 голосов
Правильный ответ

Program primer1;

var
  a: array[1..100] of integer;
  n, i, max, min: integer;

begin
  Randomize;
  Write('Введите число элементов от 1 до 100: ');
  Readln(n);
  max := -32768;
  min := 32767;
  Writeln('Исходный ряд чисел');
  for i := 1 to n do
  begin
    a[i] := Random(101) - 50;
    Write(a[i], ' ');
    if max < a[i] then max := a[i]
    else if min > a[i] then min := a[i];
  end;
  Writeln(#13#10, 'Максимум: ', max, ', минимум: ', min);
end.

Тестовое решение:
Введите число элементов от 1 до 100: 24
Исходный ряд чисел
40 -14 -12 13 44 -48 -19 11 -50 -2 -49 -6 45 49 -44 4 -7 -50 -31 18 37 44 30 -2
Максимум: 49, минимум: -50

(142k баллов)