Написать программу вычисления значения функции x^2 x>5y= 17x-1 npи -7<х<=5 25 при x<=-7

0 голосов
39 просмотров

Написать программу вычисления значения функции

x^2 x>5
y= 17x-1 npи -7<х<=5<br> 25 при x<=-7


Информатика (67 баллов) | 39 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  x,y:real;
 
begin
  Write('Введите значение аргумента x: ');
  Readln(x);
  if x<=-7 then y:=25<br>  else
    if x<=5 then y:=17*x-1<br>    else y:=sqr(x);
  Writeln('Значение функции равно ',y:0:4)
end.

Тестовое решение:
Введите значение аргумента x: 3.78
Значение функции равно 63.2600



(142k баллов)