Написать программу, которая решает уравнение ax+b = 0 (Паскаль)использовать эти ур. в...

0 голосов
43 просмотров

Написать программу, которая решает уравнение ax+b = 0 (Паскаль)
использовать эти ур. в качестве решения: 2x+4=0; 2x+0=0; 0x+2=0; 0x+0=0


Информатика (238 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

Var a,b,x:real;
begin
writeln('Введите значение a');
readln(a);
writeln('Введите значение b');
readln(b);
x:=((-1)*b)/a;
if (a=0) and (b=0)then writeln('х-любое число')
else if (a=0) and (b<>0) then writeln('Нет корней')
else writeln('x=',x);
end.

(13.4k баллов)