Нужно написать программу ** языке Турбо Паскаль, которая бы вычисляла значение выражения...

0 голосов
50 просмотров

Нужно написать программу на языке Турбо Паскаль, которая бы вычисляла значение выражения по формуле
(a/c)*(b/d)-((a*b-c)/(c*d))* e^{x+y}

e^(x+y) - степень!

Заранее спасибо


Информатика (395 баллов) | 50 просмотров
0

е - это переменная или "число е" - основание натурального логарифма?

0

переменная)

Дан 1 ответ
0 голосов
Правильный ответ

Var
  a, b, c, d, e, x, y, z: real;

begin
  Write('Введите через пробел a,b,c,d,e,x,y: ');
  Readln(a, b, c, d, e, x, y);
  if e > 0 then
    Writeln((a / c) * (b / d) - ((a * b - c) / (c * d)) * exp((x + y) * ln(e)))
  else if e = 0 then Writeln((a / c) * (b / d) - ((a * b - c) / (c * d)))
  else Writeln('e<0 недопустимо!')<br>end.

(142k баллов)