Помогите , пожалуйста, с решением двух задач ! Очень срочно. Нужно написать программу **...

0 голосов
50 просмотров

Помогите , пожалуйста, с решением двух задач ! Очень срочно. Нужно написать программу на Паскаль, заранее, спасибо!)
В двумерном массиве 5 x 5, заполненный случайными числами, найти количество положительных элементовДан двумерный массив A[n,n]. Сформировать одномерный массив В, состоящий только их элементов главной диагонали.


Информатика (12 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

Var a: array[1..5,1..5] of integer;
pol,i,j:integer;
begin 
randomize;
for i:=1 to 5 do 
 for j:=1 to 5 do  a[i,j]:=random(100)-50;
for i:=1 to 5 do
  for j:=1 to 5 do  if a[i,j]>0 then inc(pol);
write(pol);
end.

(80 баллов)
0

var a: array[1..5,1..5] of integer;
b:array[1..5] of integer;
i,j:integer;
begin
randomize;
for i:=1 to 5 do
for j:=1 to 5 do
a[i,j]:=random(100)-50;
for i:=1 to 5 do
b[i]:=a[i,i];
end.

0

Спасибо !!)