Написать программу проверки знания истории архитектуры. Программа должна вывести вопроси...

0 голосов
269 просмотров
Написать программу проверки знания истории архитектуры. Программа должна вывести вопроси три варианта ответа. Пользователь должен выбрать правильный ответ и ввести его номер.Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).
Архитектор Исаакиевского собора:
1. Доменико Трезини
2. Огюст Монферран
3. Карл Росси
Введите номер правильного ответа и нажмите
= 2
Правильно.
Архитектор Исаакиевского собора - Огюст Монферран

на языке Turbo Pascal

Информатика (1.6k баллов) | 269 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Вот скачай и все впринципе_))))

(851 баллов)
0

спасибо :)

0

нз

0 голосов

Uses crt;
Var a:integer;
Begin       
clrscr;       
writeln('Архитектор Исаакиевского собора: ');       
writeln('1. Доменико Трезини');       
writeln('2. Огюст Монферран');       
writeln('3. Карл Росси');       
writeln('Введите номер правильного ответа и нажмите ');       
readln(a);       
if a=2 then writeln('Правильно.
Архитектор Исаакиевского собора - Огюст Монферран')       
else writeln('Не правельно');       
readln;       
end.

(471 баллов)
0

clrscr; - не распознает данное выражение

0

удалил его и заработало всё

0

строкой Uses crt; ты подключаешь модуль специальный и clrscr; очистка экрана. Во free pascal работает и в турбо должно работать =)